24SevenOffice - Service disruption

Incident Report for 24SevenOffice

Resolved

This incident has been resolved.
Posted May 26, 2025 - 23:36 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 26, 2025 - 23:28 CEST

Update

We are continuing to work on a fix for this issue.
Posted May 26, 2025 - 23:04 CEST

Identified

We have identified the source of the issue and are working to stabilize.
Posted May 26, 2025 - 22:12 CEST

Investigating

We are getting reports of users being sent in a loop in 24SevenOffice. We are investigating.
Posted May 26, 2025 - 21:47 CEST
This incident affected: Application and API.