Users may experience issues logging in to Busy

Incident Report for 24SevenOffice

Resolved

This incident has been resolved.
Posted Dec 16, 2025 - 11:22 CET

Monitoring

We have restored the faulty data and are monitoring.
Posted Dec 16, 2025 - 10:36 CET

Identified

Some users may have trouble logging in to Busy. We’ve identified the cause and are working to restore normal service.
Posted Dec 16, 2025 - 09:34 CET
This incident affected: Application, API, and Mobile applications.