24SevenOffice Payroll is down

Incident Report for 24SevenOffice

Resolved

This incident has been resolved.
Posted Feb 08, 2024 - 14:10 CET

Monitoring

Service is online again.
Posted Feb 08, 2024 - 12:42 CET

Identified

Server is down again. Awaiting feedback from provider.
Posted Feb 08, 2024 - 12:37 CET

Monitoring

Payroll is back up. We are monitoring.
Posted Feb 08, 2024 - 12:21 CET

Investigating

Our provider is experiencing problems, they are investigating.
Posted Feb 08, 2024 - 11:20 CET