We are currently investigating an issue affecting login to our services

Incident Report for 24SevenOffice

Resolved

This incident has been resolved.
Posted Apr 22, 2026 - 21:10 CEST

Monitoring

Problem seems to have resolved, we are investigating the root cause.
Posted Apr 22, 2026 - 20:54 CEST

Investigating

We are currently investigating an issue affecting login to our services. The problem appears to be related to Auth0, which is impacting authentication for some or all users. We are actively monitoring the situation and working to assess the impact on our services.
Posted Apr 22, 2026 - 20:45 CEST
This incident affected: Application.