We're investigating an performance issue in our application
Incident Report for 24SevenOffice
Resolved
We've resolved this issue
Posted Aug 22, 2024 - 17:12 CEST
Update
We are continuing to investigate this issue.
Posted Aug 22, 2024 - 16:34 CEST
Investigating
We currently a performance issue in our application.
More info will follow.
Posted Aug 22, 2024 - 15:32 CEST
This incident affected: Application.