We're investigating problems reported by several customers
Incident Report for 24SevenOffice
Resolved
This incident has been resolved.
Posted Aug 04, 2022 - 12:25 CEST
Investigating
We're currently investigating problems reported by several customers.
More info will follow.
Posted Aug 04, 2022 - 10:26 CEST
This incident affected: Application.