Login problems
Incident Report for 24SevenOffice
Resolved
This incident has been resolved.
Posted Sep 05, 2024 - 09:30 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 05, 2024 - 09:23 CEST
Investigating
Some customers experience login problems. We are investigating this issue.
Posted Sep 05, 2024 - 09:15 CEST
This incident affected: Application, API, and Mobile applications.