We're investigating an elevated error rate in our application
Incident Report for 24SevenOffice
Resolved
This incident has been resolved.
Posted Sep 28, 2022 - 18:07 CEST
Update
We are continuing to investigate this issue.
Posted Sep 28, 2022 - 15:53 CEST
Update
We are continuing to investigate this issue.
Posted Sep 28, 2022 - 15:20 CEST
Investigating
We currently experiencing problems with the VAT Report. We are actively investigating the issue.
More info will follow.
Posted Sep 28, 2022 - 14:56 CEST
This incident affected: Application.